batch ingestion: mysql connection issue

I am new to druid, but I am already amazed at the architecture, and very excited to starting to use this, and hopefully contribute to the community.

I am able to run many example queries already, but I am running into issues when I try batch ingestion:

MySql in installed at this location: /usr/local/mysql/bin/mysql (mac)

When I run this:

java -Xmx2g -Duser.timezone=UTC -Dfile.encoding=UTF-8 -classpath lib/*:config/overlord io.druid.cli.Main server overlord

I am getting these errors. Any config I am missing? Thanks!

2015-06-15T23:45:33,894 INFO [LeaderSelector-0] io.druid.curator.discovery.CuratorServiceAnnouncer - Announcing service[DruidNode{serviceName=‘druid/overlord’, host=‘localhost’, port=8090}]
2015-06-15T23:46:32,809 WARN [config-manager-0] io.druid.common.config.ConfigManager - Exception when checking property[worker.config]
org.skife.jdbi.v2.exceptions.UnableToObtainConnectionException: java.sql.SQLException: Cannot create PoolableConnectionFactory (java.net.ConnectException : Error connecting to server localhost on port 1,527 with message Connection refused.)
at org.skife.jdbi.v2.DBI.open(DBI.java:210) ~[jdbi-2.32.jar:?]
at org.skife.jdbi.v2.DBI.withHandle(DBI.java:257) ~[jdbi-2.32.jar:?]
at io.druid.metadata.SQLMetadataConnector.lookup(SQLMetadataConnector.java:337) ~[druid-server-0.7.3.jar:0.7.3]
at io.druid.common.config.ConfigManager.poll(ConfigManager.java:106) [druid-common-0.7.3.jar:0.7.3]
at io.druid.common.config.ConfigManager.access$600(ConfigManager.java:42) [druid-common-0.7.3.jar:0.7.3]
at io.druid.common.config.ConfigManager$PollingCallable.call(ConfigManager.java:248) [druid-common-0.7.3.jar:0.7.3]
at io.druid.common.config.ConfigManager$PollingCallable.call(ConfigManager.java:232) [druid-common-0.7.3.jar:0.7.3]
at com.metamx.common.concurrent.ScheduledExecutors$2.run(ScheduledExecutors.java:99) [java-util-0.27.0.jar:?]
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471) [?:1.7.0_79]
at java.util.concurrent.FutureTask.run(FutureTask.java:262) [?:1.7.0_79]
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:178) [?:1.7.0_79]
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:292) [?:1.7.0_79]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [?:1.7.0_79]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [?:1.7.0_79]
at java.lang.Thread.run(Thread.java:745) [?:1.7.0_79]
Caused by: java.sql.SQLException: Cannot create PoolableConnectionFactory (java.net.ConnectException : Error connecting to server localhost on port 1,527 with message Connection refused.)
at org.apache.commons.dbcp2.BasicDataSource.createPoolableConnectionFactory(BasicDataSource.java:2152) ~[commons-dbcp2-2.0.1.jar:2.0.1]
at org.apache.commons.dbcp2.BasicDataSource.createDataSource(BasicDataSource.java:1903) ~[commons-dbcp2-2.0.1.jar:2.0.1]
at org.apache.commons.dbcp2.BasicDataSource.getConnection(BasicDataSource.java:1413) ~[commons-dbcp2-2.0.1.jar:2.0.1]
at org.skife.jdbi.v2.DataSourceConnectionFactory.openConnection(DataSourceConnectionFactory.java:36) ~[jdbi-2.32.jar:?]
at org.skife.jdbi.v2.DBI.open(DBI.java:192) ~[jdbi-2.32.ja

under config/overlord/runtime.properties:

Default host: localhost. Default port: 8090. If you run each node type on its own node in production, you should override these values to be IP:8080

#druid.host=localhost
#druid.port=8090
druid.service=overlord

Run the overlord in local mode with a single peon to execute tasks

This is not recommended for production.

druid.indexer.queue.startDelay=PT0M

This setting is too small for real production workloads

druid.indexer.runner.javaOpts="-server -Xmx256m"

These settings are also too small for real production workloads

Please see our recommended production settings in the docs (http://druid.io/docs/latest/Production-Cluster-Configuration.html)

druid.indexer.fork.property.druid.processing.numThreads=1
druid.indexer.fork.property.druid.computation.buffer.size=100000000

Please ignore…the following worked.

java -Xmx2g -Duser.timezone=UTC -Dfile.encoding=UTF-8 -classpath config/_common:config/overlord:lib/*:/server/hadoop/share/hadoop/mapreduce/conf io.druid.cli.Main server overlord