Bug in batch-indexing?

I experiences a strange behavior.
I am batch loading daily historical data (day by day) using the attached index-JSON file, where the interval is declared (e.g.) as:
“granularitySpec”: {
“type”: “uniform”,
“segmentGranularity”: “DAY”,
“granularity”: {“type”: “period”, “period”: “PT5M”},
“intervals”: [“2015-09-08T00:00:00+01:00/2015-09-08T23:59:59+01:00”]
}

The index task log-file (attached), instead reports:

...
"granularitySpec" : {
        "type" : "uniform",
        "segmentGranularity" : "DAY",
        "queryGranularity" : {
          "type" : "none"
        },
        "intervals" : [ "2015-09-08T01:00:00.000+02:00/2015-09-09T00:59:59.000+02:00" ]
      }

and some rows below:

"context" : null,
  "groupId" : "index_sso_lib_skc_2016-01-27T12:32:16.753+01:00",
  "dataSource" : "sso_lib_skc",
  "interval" : "2015-09-08T00:00:00.000+02:00/2015-09-10T00:00:00.000+02:00"

Thus some events are not loaded, but also the segment related to subsequent day (if yet loaded) is overlapped.

The strange way of using +02:00 timezone is also done in metadata:

My God! It’s my fault!
On October 25 2015, at 3am, in Italy we abandoned the daylight saving time (so, before we were in +02:00 timezone).
I must better investigate.
Apologize.
Marco

Setting user.timezone to anything other than UTC is probably not a good idea.

Hi Charles,
I can agree with you, but at this time none from Druid explained the problem I encountered in https://groups.google.com/forum/#!topic/druid-user/2MoQqxMi180 , and that I was able to overcome only setting the timezone to CET.
If you have some suggestion about that, I would be happy to follow it.
Thanks,
Marco