Cannot resume druid supervisor via REST api

Hi all,

I’m new to druid. I’m ingesting data from kafka topic to Druid datasource. After some time of no new data in kafka topic, indexing tasks didn’t consume when there are new data because they are paused according to logs:

io.druid.indexing.kafka.KafkaIndexTask - Pausing ingestion until resumed

Now, I wanted to resume the supervisor via api:

curl -v -XPOST -H'Content-Type: application/json' <overlord>/druid/indexer/v1/supervisor/resumeAll

It did not return successfully:
< HTTP/1.1 405 Method Not Allowed
< Allow: HEAD,GET,OPTIONS

I tried to be specific and use the other endpoint:

curl -v -XPOST -H'Content-Type: application/json' <overlord>/druid/indexer/v1/supervisor/<supervisor id>/resume

It returns an error as well:
< HTTP/1.1 404 Not Found

This is written in the official documentation so Im wondering why it's not working on my end. And are there any other way to resume supervisor ingestion?

Any help is appreciated.

I'm using Druid 0.12.1 and Kafka 1.0.0.3.1.

Thanks.

Okay, I was able to resume my indexing tasks by sending again a similar supervisor spec I used before:

curl -XPOST -H’Content-Type: application/json’ -d @supervisor.json /druid/indexer/v1/supervisor

This successfully resumes ingesting data from my updated kafka topic :slight_smile:

I got the idea upon reading: https://druid.apache.org/docs/latest/development/extensions-core/kafka-ingestion.html