Configuring caching at the query level

Hey everyone,

For gauging query performance, I need to explicitly turn off the use of caching at the query level. In the meanwhile, both my brokers and historicals have useCache and populateCache set as true.

In my query’s queryContext field, I have set the useCache as false and it does seem to disable the usage of cache, however the documentation here: http://druid.io/docs/latest/querying/query-context.html states that the property " may be overridden in the broker or historical node configuration" which doesn’t seem to be the case.

Can you please clarify the behaviour of useCache in this respect

Regards,

Asra

Hi,

caching on brokers (or historicals) is turned on only when brokers (or historicals) are configured to use cache, query type does not exist in ‘unCacheable’ list, and the ‘useCache’ field of queryContext are set as true.

When cache is enabled, groupBy v2 can result in invalid data (https://github.com/druid-io/druid/issues/3820). This problem will be fixed in our next release 0.10.0.

Thanks,

Jihoon

2017년 3월 29일 (수) 오후 4:19, Asra Yousuf asrayousuf28@gmail.com님이 작성: