Connecting to Local data: Parse data: Fails

Hi guys,i am a new user and trying to go through the quickstart tutorial but cant get to parse my wikipedia data since when i connect to the source, it is being aggregacted into Rows and druid can not automicatically parse the data and can not detect the column either to flatten.
Any help?

My data starts with a [Row:{

Which option are you using to connect to the datasource under load data?

@Visakh.

I am using Local disk loader

Can you try using Example data option in data loader?

I am using the druid-0.17.0-incubating version and it does not have the Example data option.

Try using other option and giving spec manually

{
“type”: “index_parallel”,
“ioConfig”: {
“type”: “index_parallel”,
“firehose”: {
“type”: “http”,
“uris”: [
https://druid.apache.org/data/wikipedia.json.gz
]
}
},
“tuningConfig”: {
“type”: “index_parallel”
},
“dataSchema”: {
“dataSource”: “wikipedia”,
“granularitySpec”: {
“type”: “uniform”,
“segmentGranularity”: “DAY”,
“queryGranularity”: “HOUR”
},
“parser”: {
“type”: “string”,
“parseSpec”: {
“format”: “json”,
“timestampSpec”: {},
“dimensionsSpec”: {}
}
}
}
}

I have copied just the first line and when i try to parse the data,it is still not automatically detected and when i tried to pass using json, i get error saying “Error:Failed to sample data:json can not be null or empty”.
What might i be doing wrong.

I input the column name “time” and the Expr “$.time” and the type set to “path”.