Coordinator hang?

hi, guys

I have a cluster with 4 historical nodes. 3 nodes (A,B,C) have little disk space, 1 node (D) have big disk space. I configured loadFator to 1.

It worked OK, but recently when new segments are produced, they seems not loaded into historical nodes (even after hours).

I looked into coordinator log, it seems that it was just assigning already loaded segments (in D) into other historical nodes (A,B,C),

but not assign new segments into any historical nodes.

Only when I restart coordinate, new segments are assigned and loaded.

But after some hours, it again ignores new created segments.

I tried upgrade from 0.8.3-rc5 to 0.9.0-snapshot ( a version near 2016-01-06), the problem remains.

Is this problem caused by balancing segments between historical? Should I setup different tiers for different configured machines? Or is it a bug?

Appreciate your reply :slight_smile:

I found that this problem is caused by OutOfMemory error.
After I increased Xmx to 10g, coordinator works fine.

在 2016年3月9日星期三 UTC+8下午2:10:42,李斯宁写道:

Hi, how many segments do you have that can cause an OOM for the coordinator?