DB password appearing in overlord logs

Hi All,

DB password is appearing in clear text in overlord logs, is there anyway to hide it ?

Thanks

Hi Chetan,
I guess the password is being printed when the overlord/middlemanager creates a task.

Can you confirm that its getting printed at the same place in your case ?

Hi Nishant,

It does on startup at overlord. its printing near to string “druid.metadata.storage.connector.password”.

Sample logs.

2016-07-13T12:24:02,025 INFO [main] io.druid.cli.CliOverlord - Starting up with processors[16], memory[4,181,590,016].

2016-07-13T12:24:02,026 INFO [main] io.druid.cli.CliOverlord - * awt.toolkit: sun.awt.X11.XToolkit

2016-07-13T12:24:02,026 INFO [main] io.druid.cli.CliOverlord - * druid.cache.sizeInBytes: 536870912

2016-07-13T12:24:02,026 INFO [main] io.druid.cli.CliOverlord - * druid.cache.type: local

2016-07-13T12:24:02,026 INFO [main] io.druid.cli.CliOverlord - * druid.discovery.curator.path: /druid/discovery

2016-07-13T12:24:02,026 INFO [main] io.druid.cli.CliOverlord - * druid.emitter: logging

2016-07-13T12:24:02,026 INFO [main] io.druid.cli.CliOverlord - * druid.emitter.logging.logLevel: info

2016-07-13T12:24:02,026 INFO [main] io.druid.cli.CliOverlord - * druid.extensions.loadList: [“druid-kafka-eight”, “druid-s3-extensions”, “druid-histogram”, “druid-datasketches”, “druid-namespace-lookup”, “postgresql-metadata-storage”]

2016-07-13T12:24:02,026 INFO [main] io.druid.cli.CliOverlord - * druid.host: 10.51.13.6

2016-07-13T12:24:02,026 INFO [main] io.druid.cli.CliOverlord - * druid.indexer.logs.directory: var/druid/indexing-logs

2016-07-13T12:24:02,026 INFO [main] io.druid.cli.CliOverlord - * druid.indexer.logs.type: file

2016-07-13T12:24:02,026 INFO [main] io.druid.cli.CliOverlord - * druid.indexer.runner.type: remote

2016-07-13T12:24:02,026 INFO [main] io.druid.cli.CliOverlord - * druid.indexer.storage.type: metadata

2016-07-13T12:24:02,026 INFO [main] io.druid.cli.CliOverlord - * druid.metadata.storage.connector.connectURI: jdbc:postgresql://hostname:5432/druid

2016-07-13T12:24:02,026 INFO [main] io.druid.cli.CliOverlord - * druid.metadata.storage.connector.password: password

Thanks

Chetan

Looks like you have explicitly set druid.startup.logging.logProperties=true in your runtime.properties.
Setting it to false should disable printing these logs.

This bothered me, too. Booked a PR https://github.com/druid-io/druid/pull/3332

druid.startup.logging.maskProperties=["user", "password", "URI"]