Druid 0.10.0 with cassandra 3.0.13 as deep storage and metadata

Hello Everyone,

Druid 0.10.0 with cassandra 3.0.13

I tried to use cassandra as deep-store and metadata, for this i applied changes in

/conf/druid/ _common/common.runtime.properties

BLOCKED

For Derby server on your Druid Coordinator (only viable in a cluster with a single Coordinator, no fail-over):

##druid.metadata.storage.type=derby

##druid.metadata.storage.connector.connectURI=jdbc:derby://localhost:1527/var/druid/metadata.db;create=true

##druid.metadata.storage.connector.host=localhost

##druid.metadata.storage.connector.port=1527

##druid.storage.type=local

ADDED

druid.extensions.loadList=[“druid-cassandra-storage”]

druid.storage.type=c*

druid.storage.host=localhost:9160

druid.storage.keyspace=druid

but found that still druid is using derby , so i make the SAME CHANGES in

/conf-quickstart/druid/ _common/common.runtime.properties

But still , it is not storing anything in cassandra.

I applied all the changes required for cassandra like

1.keyspace creation

2.table creation

http://druid.io/docs/latest/operations/including-extensions.html

http://druid.io/docs/latest/dependencies/cassandra-deep-storage.html

but still when i am looking in cassandra it is showing BLANK-TABLES only.

Any idea , what am i missing ??

How could i validate /test deep-storage configurations with cassandra. above configurations details used to set. Though i am not seeing any errors / exceptions in log file.

Kindly help me moving forward …

IIRC the cassandra contrib extension only supports 2.x.

Changed cassandra 3.0.13 to cassandra 2.2.9

BUT

Still the same issue .

Uploaded data with

curl -X ‘POST’ -H ‘Content-Type:application/json’ -d @/home/SampleSales_Index_CSV_22_07_2017.json localhost:8090/druid/indexer/v1/task

Showing success

But in cassandra, still it is BLANK-TABLE.

Not able to use cassandra as deep-storage.

By checking this URL found cassandra library are not loaded,

http://xx.xx.xx.xx:8082/status

Reconfigured property-file, now i am able to see the cassandra library

like :

{"version":"0.10.0","modules":[{"name":"io.druid.storage.cassandra.CassandraDruidModule","artifact":"druid-cassandra-storage","version":"0.10.0"}],"memory":{"maxMemory":1029177344,"totalMemory":1029177344,"freeMemory":959994536,"usedMemory":69182808}}

But the problem is still there , it is throwing error that

java.lang.UnsupportedOperationException: Cassandra storage does not support indexing via Hadoop

Any help , to run the cassandra as deep-storage.