Druid(0.15) Kafka Version Issue

Hi Team,

I am facing below error while streaming data from Kafka to new Druid 0.15.1

The broker does not support LIST_OFFSETS with version in range[2,4]. The supported range is [0,1].

The solution provided in GIT is version compatibility.

https://github.com/apache/incubator-druid/issues/8279

Could you please let me know where I can find the patch for this fix.

Thanks,

Ashish

Hi Ashish,
Looks like you need to upgrade your Kafka as druid-0.15 supports kafka-0.11 or later.

Thanks,

-siva