Druid 0.8.1-RC1

Download: http://static.druid.io/artifacts/releases/druid-0.8.1-rc1-bin.tar.gz
Documentation: http://druid.io/docs/latest

Please let us know if you find any bugs. We will update this thread if we encounter any problems.

The release notes are given below in markdown:

The full list of changes can be found here

Updating from 0.8.0

New Features

  • [Experimental] Hadoop batch Re-indexing and Delta ingestion. Re-Indexing allows you to ingest existing druid segments using a new schema with certain columns removed, changed granularity etc. “Delta” Ingestion allows appending data to existing interval in a datasource. #1374

  • [Experimental] Query Time Lookups (QTL) - Ability to do limited joins at query time. Simple example use case is Country Code to Country Name #1259

  • Read Hadoop configuration file from HDFS - #1465

Improvements

  • Improved performance of Lexicographic TopNs

  • Improved Hadoop ingestion performance

  • Improved test coverage for indexing service and Druid ingestion

  • Improved test coverage for coordinator and jersey resource tests

  • Better support for null input rows during ingestion

  • More support for added for Azure deep store

  • Made Druid console a maven dependency instead of giant code dump. The coordinator’s default UI should be much improved

Bug Fixes

  • Fix inconsistent property names for druid.metadata.* properties #1469

  • JobHelper.ensurePaths will set properties from config properly #1484

  • Fix groupBy caching with renamed aggregators #1499

  • Fix leaking indexing service status nodes in ZK #1503

  • Fix caching for approximate histograms #1534

  • Fix groupBy breaking when exceeding max intermediate rows #1406

  • Fix dependency error in local index task #1616

Documentation

  • New documentation for firehoses, evaluating Druid, and plenty of fixes.

  • Improved documentation for working with CDH

Special thanks to everyone that contributed (code, docs, issues) to this release!

@drcallen

@davidanastasia

@guobingkun

@himanshug

@michaelschiff

@fjy

@krismolendyke

@nishantmonu51

@rasahner

@xvrl

@gianm

@pjain1

@samjhecht

@solimant

@Shiyu Qiu

@ubercow

@zhaown

@Qi Wang

@mistercrunch

@pdeva

@kete.yangkt

@onlychoice

@b-slim

@cheddar

@MarConSchneid

We rejiggered the way extensions are included so the RC works without having to build your own extensions.

RC2:

http://static.druid.io/artifacts/releases/druid-0.8.1-rc2-bin.tar.gz

I tried running things straight out of this tarball and FYI pull-deps or access to maven central is still needed. The specific thing I ran into was that the tarball comes with slf4j-api-1.6.4 but at runtime org.slf4j:slf4j-api:jar:1.5.6 (among others) is also needed. I think this is not a show stopper but I just wanted to note it.

Hello Fangjin and Gian,

I am working on druid 0.8.3 and having a doubts related to maven dependancies download.

My question is as below:

As Gian pointed out to one issue that even if druid 0.8.3 comes up with slf4j-api-1.6.4, why it tries to download slf4j-api-1.5.6 ? This scenario is not frequent. In my case it doesn’t try to download it from maven but I have encountered the problem once when it tried to download slf4j-api-1.5.6.

I want to know in which scenario it tries to download this particular version of slf4j-api-1.5.6? and how to avoid that?

Thanks,
Jvalant

You can see what’s pulling it in via
mvn dependency:tree -Dverbose -Dincludes=org.slf4j:slf4j-api

``

in the druid source tree for 0.8.3

I refactored the pom exclusions and maven dependencies for 0.9.0 which seems to have fixed the craziness.

Check out the difference in the command in the druid-0.8.3 tag vs the druid-0.9.0 tag