Druid 0.8.3 compile error with Jackson version 2.2.3

Because of CDH v5.4.* compatibility issues, I’ve been recompiling the druid release with jackson 2.2.3 until Druid v0.8.2 but when I tried the same thing with version 0.8.3, I got the following error :

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.2:compile (default-compile) on project druid-common: Compilation failure

[ERROR] ***/druid-0.8.3/common/src/main/java/io/druid/guice/GuiceAnnotationIntrospector.java:[44,35] cannot find symbol

[ERROR] symbol: method annotations()

[ERROR] location: variable m of type com.fasterxml.jackson.databind.introspect.AnnotatedMember

It seems Druid 0.8.3 is not compatible with jackson 2.2 any more. :frowning: (the version CDH 5.4 is using)

I tried to other workaround suggested here (http://druid.io/docs/latest/operations/other-hadoop.html) with sbt but the link is broken.

Anybody got the same issue?

Thanks,

Jaebin

Unfortunately, jackson and guava dependency issues are quite common with Druid and various Hadoop versions. Can you include all of the CDH hadoop jars in the classpath of whatever service you are running?

The correct link is :http://druid.io/docs/latest/operations/use_sbt_to_build_fat_jar.html

Do you mind submitting a fix for the documentation?

https://github.com/druid-io/druid/blob/master/docs/content/operations/other-hadoop.md

*.md should be replaced with *.html

Ok. I’m attaching all jars included from CDH 5.4.* in the classpath.

cdh-5.4-jars.txt (23.7 KB)

Not at all. Let me try it and submit a PR to fix that.

Thanks for your help, Fangjin!

Jaebin

BTW, I was able to recompile Druid v0.8.3 with jackson 2.2.3 after reverting this change on my local : https://github.com/druid-io/druid/pull/1989

That PR should be fine to revert if you are using stock druid. Reverting it will cause https://github.com/metamx/druid-spark-batch to fail though.

Thanks for confirming that, Charles.
I updated our dev cluster with that change and it’s been working fine.