Druid Caching

Hello, we are using memcached for caching results in our druid cluster.

It works well with topN queries but it does not work with groupby queries (cpus of the historical node works for every groupby queries but only works the first execution time for topn queries).

Here is our historical node configuration :

druid.historical.cache.useCache=true

druid.historical.cache.populateCache=true

druid.broker.cache.unCacheable=[“select”]

druid.cache.type=memcached

druid.cache.hosts:11211=memcacheddruid.lf2yex.0001.euw1.cache.amazonaws.com

druid.cache.maxObjectSize=524288000

druid.cache.timeout=10000

Here is our broker configuration :

druid.broker.cache.useCache=true

druid.broker.cache.populateCache=false

druid.broker.cache.unCacheable=[“select”]

druid.cache.type=memcached

druid.cache.hosts:11211=memcacheddruid.lf2yex.0001.euw1.cache.amazonaws.com

druid.cache.maxObjectSize=524288000

druid.cache.timeout=10000

thanks

Julien

Hey Julien,

You have set druid.broker.cache.unCacheable on your historical but that should be druid.historical.cache.unCacheable.

Hi Gian, it’s working fine with the good parameter for the historical.

Thanks

Julien