Druid datasource segment disappearing

I have a druid cluster (0.13.0) with s3 based deepstorage.
Through kafka indexing one datasource was created.
However the segments disappear after some time.
I also have added a retention policy of retain forever and reenabled the datasource.
Still the segments are not loaded.
They are present at s3.
Not able to figure the issue out.

Is the log relevant to the issue.
:22:53,785 INFO [BrokerServerView-0] org.apache.druid.sql.calcite.schema.DruidSchema - Removed all metadata for dataSource[parampoc3].

Please help in finding out resources which will help me in . debugging this issue

Hi Nikhil,

You should be having entries for each segment in druid_segments table in metadata store.

Do you have the corresponding segment entries in druid metadata store ?

Yes i check the metadata store for the entries

They are present

select count(*) from druid_segments where dataSource=“parampoc3” limit 1

-> ;

also, we have tried the following solution as well but doesn’t seems to be working in our case.

https://groups.google.com/forum/#!topic/druid-user/DdSz_bBsAFM

Hi Nikhil,

Can you check and share historical node logs. The issue might be there.

Check your segment location permission and partition space.

Rommel Garcia

Hi everyone,

Thank you for replying, issue seems to be fixed for now, but not sure if it is correct or not.

After modifying data retention rules, we were not able to see the old segments data.

But after taking restart of the service it worked.

Can anyone tell what should be the exact workaround for this, if i want to reload old segments?

You can re-enable your data source and define the rules for it to be available.

Rommel Garcia

Director, Field Engineering