druid does not write data on cassandra

Druid Version: 0.8.1

Druid does not write data on cassandra as i checked, but when i restart druid data still keep.

Not any meaningful log about cassandra.

There is no exception.

I just tried to read table from cassandra index_storage and descriptor storage and these are empty.

config/_common/common.runtime.properties

out of curiosity, why did you comment out druid.extensions.coordinates ?

i thought because of common configuration, maybe it cant be necessary

20 Eylül 2015 Pazar 18:34:05 UTC+3 tarihinde charles.allen yazdı:

when i restart i lose data, sorry for wrong examination

19 Eylül 2015 Cumartesi 16:19:53 UTC+3 tarihinde Yunus Ozden yazdı:

Hi Yunus, the cassandra module is community contributed and I am not sure if it actually works with Cassandra 2.x+. Do you have the output of your indexing logs? They shoudl indicate if segments are actually being written to Cassandra. Make sure the common configuration is included in the CP of any nodes that do indexing.

Problem solved, thanks

Yeah – you can blame the cassandra module on me. :wink:

The module definitely needs a refresh. It is using an old version of the Astyanax driver. (1.0.1)

https://github.com/druid-io/druid/blob/master/extensions/cassandra-storage/pom.xml

That does not work against Cassandra 2.x. That old version of Astyanax was built with 1.1.1 of the cassandra jar:

https://github.com/Netflix/astyanax/blob/astyanax-1.0.7/build.gradle

I’ll doubt I’ll have time, but the module should be ported to CQL.

-brian