Druid support for Kafka 0.7.2

Does the latest version of Druid still support ingestion from old kafka versions like 0.7.x ?

No, we removed support for 0.7.2 in 0.9.0.

We should probably add this to the release notes.