Druid Upgrade

We’re planning to upgrade from Imply 2.6 to Imply 2.9 (Druid from 0.12 to 0.14) at AWS.

What’s the suggested approach. Rolling upgrade on existing cluster or Setting up new cluster and switch?

It seems setting up new cluster and switch from the existing to the new is more controllable and safer

though it takes time to loading segments for historicals at new cluster at start.

Like to collect your experience and opinions.

Thanks,

Paul

Hi Paul,
If you have the luxury to stop your existing running cluster, it is better to stop and upgrade from 2.6 to 2.9

Otherwise, you can go for rolling upgrade but it is going to take very long time when compared against upgrade with downtime.

If you go for setting up new cluster, yes historicals has to load all the segments before you can start accessing your old data.

Thank you.

–siva