[druid-user] Kafka emitter is emiting all matrices (Druid 25.0.0)


We are using Kafka ingestion to insert data into druid. our segment granularity is 1 hour. we are getting future events and late events. so, we are having multiple segments for 1 hour (some time 100)

We are using kafka-emitter for matrices.
below matrices are generated for each segments:

  1. query/wait/time

  2. query/segmentAndCache/time

  3. query/segment/time

I want to disable those matrices.

I changed druid.monitoring.monitors configuration. but it is but working.

I kept only one value in it.

still it is emitting all matrices. I tested druid.monitoring.monitors into both configuration files, runtime.properties and common.runtime.properties

Mrugesh Kadia


I changed druid.monitoring.monitors configuration. but it is but working.

but it is not but working

Query metrics are not configured through monitors, they are emitted when emission is turned on.
But what emitter are you using? Some of the emitters have a whitelist of metrics to emit, like the graphite emitter here: Graphite Emitter · Apache Druid

we are using kafka emitter. is there any way to filter/disable some metrics?

No. It does not seem to have that option.

Are you a java programmer?
It is an open source project and that sounds like something cool to add as an option to the extension.