[druid-user] Loadrule not getting triggered regularly by Coordinator

Hi all,

We have recently seen an issue where coordinator is not triggering loadrule for around 8 hours even though data is getting inserted continuously.

Please see below logs. We see a pattern where it’s not triggering loadrule for 8 hours. Please assist if anyone has seen similar issue.

We are using Druid version 0.18.

2021-03-29T13:30:18,184 INFO [Coordinator-Exec–0] org.apache.druid.server.coordinator.rules.LoadRule - Assigning ‘primary’ for segment [abc_2021-03-29T14:00:00.000Z_2021-03-29T15:00:00.000Z
_2021-03-29T13:03:45.535Z_6] to server [10.50.86.227:8083] in tier [hot]
2021-03-29T13:30:18,186 INFO [Coordinator-Exec–0] org.apache.druid.server.coordinator.rules.LoadRule - Assigning ‘replica’ for segment [abc_2021-03-29T14:00:00.000Z_2021-03-29T15:00:00.000Z
_2021-03-29T13:03:45.535Z_6] to server [10.50.86.222:8083] in tier [hot]
--------------------------------------------------------- no load rule in coordinator --------------------------------------------------------------------------
2021-03-29T21:34:56,722 INFO [Coordinator-Exec–0] org.apache.druid.server.coordinator.rules.LoadRule - Assigning ‘primary’ for segment [abc_2021-03-29T22:00:00.000Z_2021-03-29T23:00:00.000Z_2021-03-29T21:03:33.443Z_5] to server [10.50.86.227:8083] in tier [hot]
2021-03-29T21:34:56,726 INFO [Coordinator-Exec–0] org.apache.druid.server.coordinator.rules.LoadRule - Assigning ‘replica’ for segment [abc_2021-03-29T22:00:00.000Z_2021-03-29T23:00:00.000Z_2021-03-29T21:03:33.443Z_5] to server [10.50.86.222:8083] in tier [hot]