[druid-user] Re: Connection Problem with Amazon S3 on Druid

Hey hope this helps?!

Here’s a setup I have for Minio ingestion to a prefix (rather than a specific file as you have) - notice that the first part of the s3 URI is the bucket, not the server name. Maybe that is part of the problem?

Check out here also for some other config options.

Also, did you set the S3 configuration? I’ve not used Stook - but I have used Min.io perfectly fine for deep storage, task logs, and ingestion. I found guidance from Hagen Rother who’s awesome :). So I added the settings for all the s3 stuff:

  • druid.s3.accessKey=yourkey
  • druid.s3.secretKey=yoursecret
  • druid.s3.protocol=http
  • druid.s3.enablePathStyleAccess=true
  • druid.s3.endpoint.signingRegion=us-east-1
  • druid.s3.endpoint.url=[where is Stook]:[Stook Port]/

Now I didn’t test if this was strictly necessary, but this great article said I needed to set the jets3t properties file in the class path. So I created mine as per the article as follows. I don’t know if I needed to do this though…

  • s3service.s3-endpoint=[where is Stook]
  • s3service.s3-endpoint-http-port=9000
  • s3service.disable-dns-buckets=true
  • s3service.https-only=false