[druid-user] Re: Hello world of Apache Druid doesn't work for docker-compose

I was able to reproduce your results. The short story is that you need to add more memory to the Resources in Docker, I bumped it up to 8GB and that did it.

Longer story:

Before I could get it to “work”, I ran into an issue in the environment file which is seemingly different on Ubuntu, but on Mac OS, environment variables cannot have spaces unless they are surrounded by single or double quotes so I had to change the variables in the environment file as follows:


druid_extensions_loadList=[“druid-histogram”, “druid-datasketches”, “druid-lookups-cached-global”, “postgresql-metadata-storage”]

became this (notice the surrounding single quotes in the variable value):

druid_extensions_loadList=[“druid-histogram”, “druid-datasketches”, “druid-lookups-cached-global”, “postgresql-metadata-storage”]'

and also for these two variables:

druid_indexer_runner_javaOptsArray=["-server", “-Xmx1g”, “-Xms1g”, “-XX:MaxDirectMemorySize=3g”, “-Duser.timezone=UTC”, “-Dfile.encoding=UTF-8”, “-Djava.util.logging.manager=org.apache.logging.log4j.jul.LogManager”]'

DRUID_LOG4J='<?xml version="1.0" encoding="UTF-8" ?>

After that I ran docker-compose up which resulted in the same situation you describe, except the failed containers were broker and historical in my case.

In the docker compose output noticed that the broker and historical failed with:

broker exited with code 137

historical exited with code 137

Googled it and found that containers fail with that error when there isn’t enough memory available to docker. Increased memory and reran docker-compose up successfully.

Hope this helps,