Enabling debug logging

Hi,

Quick question.

Using a realtime node and kafka 8 firehose to ingest a ton of events. seems like all of them are unparseable and im not sure why? i get this error:

ERROR [MonitorScheduler-0] io.druid.segment.realtime.RealtimeMetricsMonitor - [54,704] Unparseable events! Turn on debug logging to see exception stack trace.

I have these lines in my realtimes runtime.properties:

druid.monitoring.monitors=[“io.druid.segment.realtime.RealtimeMetricsMonitor”]

druid.emitter=logging

druid.emitter.logging.logLevel=info

I do see logs but I am not able to see the exception from this error. How can i enable logging to see this exception?

Thanks,

anyone?

You’ll want to specify a log4j2.xml. There’s one in the druid repository for debugging on EVERYTHING in druid, you may want to change the name=“io.druid” to name=“io.druid.segment.realtime” if the log is too chatty and you’re using the realtime node.

http://druid.io/docs/0.8.0/configuration/logging.html

– Himanshu

Charles’ suggestion is what worked for me. Thanks guys.

How exactly do you do this?

Hi Mark,

You can edit the log4j2.xml that is bundled in conf/_common/.

Hi charles! I search log4j2.xml and found it under _common/ but could not find property “name=io.druid” except

dont know how to resolve my problem

  1. You would need to add an entry to the file:

Giving u file that looks like: (for level you can use trace,info,debug,warn)