Ensure the Druid Overlord and Coordinator logs are kept for 7 days

Hi

I’m new on Druid

I need to increase the log retention for the Overlord and Coordinator

As of today, the Druid Overlord and Coordinator logs only appear to be kept for about an hour. Update this so that logs are available for 7 days.

Can anyone help me?

Regards

Hi Jennifer,

In the default configuration, logs are written to standard out. If you have a 7 day retention it is likely due to something you have implemented on your end so I would try double-checking that. There may be some clues in conf/_common/log4j2.xml or conf/druid/_common/log4j2.xml.

Hi Gian

only register for one hour and would like to keep it for 7 days

Hello Gian
I have this on my druid-playbooks/files/configs/_common/log4j2.xml

<?xml version="1.0" encoding="UTF-8" ?> And my [druid-playbooks](https://github.homeawaycorp.com/AnalyticsEngineering/druid-playbooks)/[files](https://github.homeawaycorp.com/AnalyticsEngineering/druid-playbooks/tree/master/files)/[configs](https://github.homeawaycorp.com/AnalyticsEngineering/druid-playbooks/tree/master/files/configs)/[_common](https://github.homeawaycorp.com/AnalyticsEngineering/druid-playbooks/tree/master/files/configs/_common)/**common.runtime.properties.j2 have this** druid.extensions.loadList=["druid-avro-extensions", "druid-kafka-eight", "druid-kafka-indexing-service", "druid-s3-extensions", "druid-histogram", "druid-datasketches", "druid-lookups-cached-global", "mysql-metadata-storage"]

druid.startup.logging.logProperties=true

druid.exhibitor.service.hosts=["{{ zk_address }}"]

druid.exhibitor.service.port=8181

druid.zk.service.host={{ zk_address }}

druid.zk.paths.base=/druid

druid.metadata.storage.type=mysql

druid.metadata.storage.connector.connectURI=jdbc:mysql://{{ db_address }}:3306/druid

druid.metadata.storage.connector.user={{ db_user }}

druid.metadata.storage.connector.password={{ db_password }}

druid.storage.type=s3

druid.storage.bucket={{ s3_bucket }}

druid.storage.baseKey=druid/segments

druid.indexer.logs.type=file

druid.indexer.logs.directory=/var/druid/indexing-logs

druid.indexer.logs.type=s3

druid.indexer.logs.s3Bucket={{ s3_bucket }}

druid.indexer.logs.s3Prefix=druid/indexing-logs

druid.selectors.indexing.serviceName=druid/overlord

druid.selectors.coordinator.serviceName=druid/coordinator

druid.monitoring.monitors=[“com.metamx.metrics.JvmMonitor”]

druid.emitter=logging

druid.emitter.logging.logLevel=info

druid.javascript.enabled=true