Err : druid.segmentCache.locations - may not be empty : Historical Server

Hi,

I am not able to start the Historical Server. I am getting the bellow error message.

Thanks in advance.

druid.segmentCache.locations - may not be empty

at io.druid.guice.JsonConfigProvider.bind(JsonConfigProvider.java:131)

at io.druid.guice.JsonConfigProvider.bind(JsonConfigProvider.java:131)

while locating com.google.common.base.Supplier<io.druid.segment.loading.SegmentLoaderConfig>

at io.druid.guice.JsonConfigProvider.bind(JsonConfigProvider.java:132)

while locating io.druid.segment.loading.SegmentLoaderConfig

for parameter 1 at io.druid.segment.loading.SegmentLoaderLocalCacheManager.(SegmentLoaderLocalCacheManager.java:57)

while locating io.druid.segment.loading.SegmentLoaderLocalCacheManager

at io.druid.guice.LocalDataStorageDruidModule.configure(LocalDataStorageDruidModule.java:49)

while locating io.druid.segment.loading.SegmentLoader

for parameter 0 at io.druid.server.coordination.ServerManager.(ServerManager.java:107)

at io.druid.cli.CliHistorical$1.configure(CliHistorical.java:77)

while locating io.druid.server.coordination.ServerManager

at io.druid.cli.CliHistorical$1.configure(CliHistorical.java:79)

while locating io.druid.query.QuerySegmentWalker

for parameter 3 at io.druid.server.QueryResource.(QueryResource.java:90)

while locating io.druid.server.QueryResource

1 error

at com.google.inject.internal.InjectorImpl$3.get(InjectorImpl.java:1014) ~[guice-4.0-beta.jar:?]

at com.google.inject.internal.InjectorImpl.getInstance(InjectorImpl.java:1036) ~[guice-4.0-beta.jar:?]

at io.druid.guice.LifecycleModule$2.start(LifecycleModule.java:153) ~[druid-api-0.3.13.jar:0.8.2]

at io.druid.cli.GuiceRunnable.initLifecycle(GuiceRunnable.java:71) [druid-services-0.8.2.jar:0.8.2]

at io.druid.cli.ServerRunnable.run(ServerRunnable.java:38) [druid-services-0.8.2.jar:0.8.2]

at io.druid.cli.Main.main(Main.java:91) [druid-services-0.8.2.jar:0.8.2]

Thanks,

Apurba Pandey

Hi,
you need to specify druid.segmentCache.locations in runtime.props for your historical nodes.

See http://druid.io/docs/latest/configuration/historical.html

Hi Nishant,

Thanks for your reply. It was already added. Please find the attached historical/runtine.prop file.

Thanks,

Apurba Pandey

runtime.properties (1.51 KB)

Hi,
apart from an extra escape character after maxSize, the config seems fine.

Can you try removing that and adding the new file to the classpath ?