Error when running Druid SQL queries in tutorial

hi there,

I was following the tutorial on Druid website, however when I run the Druid SQL command, it gave me this error bash: syntax error near unexpected token `(', does anyone face the same error before?

SELECT page, COUNT(*) AS Edits FROM wikipedia WHERE "__time" BETWEEN TIMESTAMP '2015-09-12 00:00:00' AND TIMESTAMP '2015-09-13 00:00:00' GROUP BY page ORDER BY Edits DESC LIMIT 10;

Hi,

the same query works for me. How did you run the query? Did you submit the query using curl?

Jihoon

Hi,

This seems like a Bash error, are you sending the SQL query text as part of the bash command?

You should submit the SQL using a file, just as with JSON queries. please check this example from the same document page:

TopN query example

The tutorial package includes an example file that contains the SQL query shown above at examples/wikipedia-top-pages-sql.json. Let’s submit that query to the Druid broker:

curl -X 'POST' -H 'Content-Type:application/json' -d @examples/wikipedia-top-pages-sql.json [http://localhost:8082/druid/v2/sql](http://localhost:8082/druid/v2/sql)

Hi, I am submitting in bash.

Hi!

Thanks for the help, I should have read further!

Ronnie