Exception for org.apache.calcite.config.CalciteConnectionProperty

Trying to test built-in SQL.

I build the package from latest in GIT, but broker gets an exception when “druid.sql.enable=true”. Broker works fine when “druid.sql.enable=false”.

One server setup, using mostly quickstart-conf (see below for some changes).

Some configuration missing in my setup? help appreciated.

I have verified that the same exception is happening with an unmodified package (except for appending “druid.sql.enable=true” in broker runtime.properties).

Build done using latest master branch and I do “mvn clean package” to produce the package.

Host is an EC2 running Amazon Linux AMI

Hey Mario,

I think this problem is caused by having multiple versions of avatica on the classpath. This patch should fix it: https://github.com/druid-io/druid/pull/3813

This patch fix the problem.

I am able to do SQL queries now.

Thanks Gian for both the feature and support.