Graphite-emitter extension missing?

According to:

https://druid.apache.org/docs/latest/development/extensions-contrib/graphite.html

The extension must be enabled.

So when I add it, it complains say it doesn’t exist!

has the extension been removed?

(I added this to my _common/common.runtime.properties)

druid.extensions.loadList=[“druid-basic-security”,“druid-s3-extensions”,“druid-kafka-indexing-service”,“mysql-metadata-storage”,“graphite-emitter”]

This is the error on start.

2019-10-02T18:12:19,072 INFO [main] org.apache.druid.guice.JsonConfigurator - Loaded class[class org.apache.druid.common.config.NullValueHandlingConfig] from props[druid.generi
c.] as [org.apache.druid.common.config.NullValueHandlingConfig@cd1d761]
2019-10-02T18:12:19,122 INFO [main] org.apache.druid.guice.JsonConfigurator - Loaded class[class org.apache.druid.guice.ExtensionsConfig] from props[druid.extensions.] as [Exte
nsionsConfig{searchCurrentClassloader=true, directory=‘dist/druid/extensions’, useExtensionClassloaderFirst=false, hadoopDependenciesDir=‘dist/druid/hadoop-dependencies’, hadoo
pContainerDruidClasspath=‘null’, addExtensionsToHadoopContainer=false, loadList=[druid-basic-security, druid-s3-extensions, druid-kafka-indexing-service, mysql-metadata-storage
, graphite-emitter]}]
Exception in thread “main” org.apache.druid.java.util.common.ISE: Extension [/home/centos/app/imply-3.0.13/dist/druid/extensions/graphite-emitter] specified in “druid.extension
s.loadList” didn’t exist!?
at org.apache.druid.initialization.Initialization.getExtensionFilesToLoad(Initialization.java:247)
at org.apache.druid.initialization.Initialization$ServiceLoadingFromExtensions.addAllFromFileSystem(Initialization.java:175)
at org.apache.druid.initialization.Initialization$ServiceLoadingFromExtensions.(Initialization.java:163)
at org.apache.druid.initialization.Initialization$ServiceLoadingFromExtensions.(Initialization.java:149)
at org.apache.druid.initialization.Initialization.lambda$getFromExtensions$0(Initialization.java:143)
at java.util.concurrent.ConcurrentHashMap.compute(ConcurrentHashMap.java:1853)
at org.apache.druid.initialization.Initialization.getFromExtensions(Initialization.java:141)
at org.apache.druid.cli.Main.main(Main.java:103)
2019-10-02T18:12:23,313 INFO [main] org.apache.druid.guice.PropertiesModule - Loading properties from common.runtime.properties
2019-10-02T18:12:23,316 INFO [main] org.apache.druid.guice.PropertiesModule - Loading properties from runtime.properties
2019-10-02T18:12:23,345 INFO [main] org.hibernate.validator.internal.util.Version - HV000001: Hibernate Validator 5.1.3.Final
2019-10-02T18:12:23,797 INFO [main] org.apache.druid.guice.JsonConfigurator - Loaded class[class org.apache.druid.common.config.NullValueHandlingConfig] from props[druid.generi
c.] as [org.apache.druid.common.config.NullValueHandlingConfig@cd1d761]

``

Hi Daniel,

A number of community members have contributed their own extensions to Druid that are not packaged with the default Druid tarball. If you’d like to take on maintenance for a community extension, please post on dev@druid.apache.org to let us know!

All of these community extensions can be downloaded using pull-deps while specifying a -c coordinate option to pull org.apache.druid.extensions.contrib:{EXTENSION_NAME}:{DRUID_VERSION}.

Please refer Community extensions section for more details :

https://druid.apache.org/docs/latest/development/extensions.html#loading-extensions

Hope this helps.

Thanks ,

Vaibhav