How to disable metric log messages org.apache.druid.java.util.emitter.core.LoggingEmitter - Event

Hey All,

I am new to Druid and following the quickstart documentation from the druid website.

I wish to disable druid service publishing metrics in the logs file.

for ex:

2019-03-18T19:57:12,479 INFO [MonitorScheduler-0] org.apache.druid.java.util.emitter.core.LoggingEmitter - Event [{“feed”:“metrics”,“timestamp”:“2019-03-18T19:57:12.479Z”,“service”:“druid/broker”,“host”:“localhost:8082”,“version”:“0.13.0-incubating”,“metric”:“jvm/pool/init”,“value”:2555904,“poolKind”:“nonheap”,“poolName”:“Code Cache”}]

I have commented the below lines in apache-druid-0.13.0-incubating/conf/druid/_common/common.runtime.properties but still I see the emitter logs.

#druid.monitoring.monitors=[“org.apache.druid.java.util.metrics.JvmMonitor”]

#druid.emitter=logging

#druid.emitter.logging.logLevel=debug

log4j2.xml

Hi,

Have you tried setting druid.emitter to noop?

  • Justin

Thanks. Forgot to update here.