How to reload segment on hdfs after increasing rules load time?

Hi Experts,

First, I set the rules to load the segment in latest 5 days. So the segments 6 days ago will be dropped by coordinator and historical nodes of course. As we know the outdated segments are still on the deep storage. However the coordinator and historical nodes wont load the dropped segments after I increasing the rule load time from 5 days to 10 days, even after I restarted the coordinator and historical nodes, or manually update the ‘used’ value from 0 to 1 in MySQL druid_segments table.

How to let Druid to reload the outdated segment after increasing the rules load window preiod?

Thanks in advance!

Are you sure you don’t have another drop rule for segment older than 5 days ?

Qiyun,
you have to enable the segments via the coordinator by sending a post to this uri.I created a list of segment ids by querying mysql.

  • /druid/coordinator/v1/datasources/{dataSourceName}/segments/{segmentId}
    more docs here

http://druid.io/docs/0.8.3/design/coordinator.html

Hi Pedro and Slim,

Thank all of you! It works for me after sending above post to coordinator.

在 2016年3月15日星期二 UTC+8上午5:20:34,Pedro Neves写道: