[Imply] Cannot start up because port[1527] is already in use.

Hi all,

May I know how to change the imply port number not to conflict with existing one?

[cloudera@quickstart imply-1.2.1]$ bin/supervise -c conf/supervise/quickstart.conf

Warning: Use of “localtime” without parentheses is ambiguous at bin/supervise line 16.

Warning: Use of “localtime” without parentheses is ambiguous at bin/supervise line 23.

Cannot start up because port[1527] is already in use.

Please kindly help.

Thanks a lot.

This is a support forum for Druid rather than Imply. (its kind of like posting in a Hadoop forum with questions about Cloudera). So you might get some answers but if what you get here doesn’t work be sure to ask in the Imply forums.

Looks like you have multiple instances of Derby running and the later ones can’t start since the port is already bound?

Thanks a lot.

I thought Imply is one of the members under Druid family, and then once I installed this. I have check some config files under /imply-1.2.1/conf/supervise directory, but I can’t find anywhere to change the port setting.

So, that is why I ask this.

charles.allen於 2016年5月12日星期四 UTC+8上午11時20分44秒寫道:

Hey Bryan,

Charles has the relationship right, a lot of us from Imply are here in the Druid forums too, although that “supervise” program is an Imply thing. Anyway, port 1527 is Derby, so like Charles said you probably have another Derby DB running somewhere. You could try one of the following two things to get around that:

  1. Avoid port conflicts by running the quickstart in its own VM or container. Docker might make this easier. We have a quickstart Docker image here: https://hub.docker.com/r/imply/imply/

  2. You can change Druid’s Derby port by adjusting the druid.metadata.storage.connector.connectURI and druid.metadata.storage.connector.port properties in common.runtime.properties. For the Imply quickstart this is located in conf-quickstart/druid/_common/common.runtime.properties. You’ll also need to comment out or remove the “:verify bin/verify-default-ports” line in conf/supervise/quickstart.conf (this is what’s printing out the “port[1527] is already in use” message).

Btw, the “Warning: Use of ‘localtime’ without parentheses is ambiguous at bin/supervise line 16.” thing is odd too, we’ll fix that.