Index Task Error : .DiskChecker$DiskErrorException: Could not find any valid local directory

Hello Druid Gurus,

i have been trying to ingest abt 16 GB data but is failing. One of the error i see consistently in the log file is ‘DiskChecker$DiskErrorException: Could not find any valid local directory’. But i am not sure if this is the only error that caused the issue. Since we dont have enough space in /tmp/ directory we changed the path in all possible runtime properties files( overlord, historical,coordinator,broker) to a directory which has enough space but still no luck. when i looked at log i see the SegmentOutputPath is still being written into /tmp/

“segmentOutputPath” : "file:///tmp/druid/localStorage/

we changed this path in runtime.properties but still doesn’t pickup the path we gave.

Attached is the log file. Can you please help?

Regards

Karteek

index_hadoop_dtmrt_pci_byr_ltime_2015-08-22T01%3A19%3A07.323Z.log (675 KB)

Hi Karteek, looking at your logs, have you tried setting hadoop.tmp.dir in your hadoop configuration files? This error seems to be a Hadoop error.