index task successful, hdfs has empty files

Hi,

The status indicated in the index task’s log file is SUCCESS and indeed it created an hdfs directory and 6 files for 6 hour segments: but they are empty!

There is plenty of hdfs space. There is no exception in log, it took much time to execute and I give below some lines from output and I summed up the processed lines and they do sum up to 3.5M.

interval[2015-07-29T18:00:00.000Z/2015-07-29T19:00:00.000Z] partition[0] took in 3,532,882 rows (275,837 processed, 0 unparseable, 3,257,045 thrown away) and output 274,848 rows

interval[2015-07-29T19:00:00.000Z/2015-07-29T20:00:00.000Z] partition[0] took in 3,532,882 rows (1,061,975 processed, 0 unparseable, 2,470,907 thrown away) and output 1,057,630 rows

interval[2015-08-06T23:00:00.000Z/2015-08-07T00:00:00.000Z] partition[0] took in 3,532,882 rows (148,350 processed, 0 unparseable, 3,384,532 thrown away) and output 147,578 rows

interval[2015-08-07T00:00:00.000Z/2015-08-07T01:00:00.000Z] partition[0] took in 3,532,882 rows (647,514 processed, 0 unparseable, 2,885,368 thrown away) and output 641,818 rows

interval[2015-08-07T01:00:00.000Z/2015-08-07T02:00:00.000Z] partition[0] took in 3,532,882 rows (509,186 processed, 0 unparseable, 3,023,696 thrown away) and output 504,897 rows

interval[2015-08-07T02:00:00.000Z/2015-08-07T03:00:00.000Z] partition[0] took in 3,532,882 rows (487,306 processed, 0 unparseable, 3,045,576 thrown away) and output 483,449 rows

interval[2015-08-07T03:00:00.000Z/2015-08-07T04:00:00.000Z] partition[0] took in 3,532,882 rows (402,714 processed, 0 unparseable, 3,130,168 thrown away) and output 400,028 rows

Please advise,

Nicu

Hi,

In fact I see the segments both in mysql and in hdfs; there is data in the index.zip , exactly what it should be 800MB.

The segments are not available: timeseries query in historical node gives empty result, and the coordinator browser console shows 0B consumed from 10GB.

Restarted zk on all 3 nodes, then stopped all druid java processes, then started zk, historical and coordinator. Same situation - no segments, tested by coordinator:8081 and by making query on historical directly - no data.

Pls advise! How did you solve this?

Thanks,

Nicu

Hi,

Solved this, was a misconfig at the historical node probably.

Thanks