Is it enough to upgrade Java JDK/JRE if still compiling with an old java.version?

I'm using an open-source project which still uses Java 8. It supports Java 11, but the pom.xml locks the compiled byte-code version to 8:


This is a companion discussion topic for the original entry at https://stackoverflow.com/questions/71169640/is-it-enough-to-upgrade-java-jdk-jre-if-still-compiling-with-an-old-java-version