Is there any way to build a recent druid version with 2.7.3 hadoop libs?

A community member was trying to build a recent version of Druid with 2.7.3 hadoop libs and encountered the following error:

[ERROR] Failed to execute goal on project druid-orc-extensions: Could not resolve dependencies for project org.apache.druid.extensions:druid-orc-extensions:jar:0.22.2-SNAPSHOT: Could not find artifact org.apache.hadoop:hadoop-hdfs-client:jar:2.7.3 in snapshot.proxy (https://:8082/repository/apache-snap/) → [Help 1]

The solution ended up being to remove the druid.indexer.task.defaultHadoopCoordinates=[] from the middlemanager runtime.properties. Here’s a bit more context.