Kafka 1.0 support for kafka-indexing-service

The docs for druid 0.11 say that kafka-indexing-servixe uses kafka 0.10 drivers.
Can it be used with Kafka 1.0?
If not, are there any plans to introduce support?

I am sure we will upgrade before too long. I haven’t checked yet if the new client supports older brokers or not; that is usually the reason we hold off upgrading. If it looks like the new client maintains decent compatibility then please feel free to open a PR upgrading our version of the client (or just file an issue if you don’t have time to write a patch).