Kill Task Exception

Hello,

I’m getting an exception when issuing a DELETE to the REST endpoint for creating a kill task per the documentation: http://druid.io/docs/0.9.0/design/coordinator.html

The exception I’m getting is:

Exception occurred. Are you sure you have an indexing service?

``

The REST endpoint I’m using is :

http://localhost:8081/druid/coordinator/v1/datasources/foo?kill=true&interval=2016-06-13T00:00:00_2016-07-01T00:00:00

``

I am able to enable and disable that datasource as well as write data using realtime tasks through Tranquility, but have not been able to figure this out.

Best Regards,

Hey Andre,

Your coordinator is probably having trouble locating the overlord through service discovery. Make sure that ‘druid.selectors.indexing.serviceName’ matches ‘druid.service’ of the overlord and that both the coordinator and overlord have the same path for ‘druid.discovery.curator.path’.

Thanks for the reply David. I checked the values you mentioned, I couldn’t find druid.discovery.curator.path; but the other values are the same.

druid.selectors.indexing.serviceName=druid/overlord
druid.service=druid/overlord

``

``

I’m running Druid 0.9.0 if it makes a difference.

I tried using the updated kill task request format (https://github.com/druid-io/druid/issues/2999#issuecomment-222810655) running Druid 0.9.1-rc3 and it worked. I just ran the quickstart config on both versions so I don’t think I mucked anything up when I was testing earlier.

Should I open an issue for this in Github for version 0.9.0? I can probably just use the new version, but maybe other people are having this issue too.

I’ll try again tomorrow morning with Druid 0.9.0 and a clean install to see what happens.

Had the same issue with a clean install of Druid 0.9.0.

That’s odd. I’m glad you got it working with the new API.

There’s probably little point in filing an issue on a deprecated endpoint since the guidance would be to move to the new one and I don’t think we’ll be making any patches to 0.9.0. This thread should be helpful to others who are encountering the same issue!