"Maximum number of rows reached" error when using query data source

Hi Druid Gurus,

i am trying to run a query which uses query as data source. Issue i am facing is, it errors out with message “Maximum number of rows reached”. i have also tried to bump some numbers on broker runtime config file but its no help. Please see below. i made sure these numbers are far more greater than total number of rows query data source returns. Is there any other setting i am missing? please help.





Hi Karteek,

What version of Druid is this? Are you getting this error on the historical node or the broker node? Those query configs seem correct for later versions of Druid, so I wonder if they are not getting picked up for some reason.

Hi Fangjin,

Sorry for the late reply. we are on version 0.8.0 and i believe we are getting this error from broker node. I see the following in broker log

INFO [qtp923953425-50] io.druid.server.QueryResource - Maximum number of rows reached [99ad2596-90a9-4d1e-a88e-46518f1d701c]



druid.query.groupBy.maxResults=20000000 should actually take care of that given that subquery result set is smaller than that. Did you configure those properties on all brokers and historicals both? I guess you are missing them from historical and that is where actually it is failing.

– Himanshu

Thank you Himanshu. I will update this setting on all historicals and will give it a try.