not able to start hadoopdruid ingester.

I have checked the similar post, but couldn’t resolve my problem.

I am trying to do start hadoopdruid ingester in standalone .

Below command I had issued for starting ingester.

java -Xmx256m -Duser.timezone=UTC -Dfile.encoding=UTF-8 -classpath lib/*:/home/hadoop-2.7.1/etc/hadoop io.druid.cli.Main index hadoop /home/ec2-user/generatedJson/basicStatsSpecs.json

The above throwing the below error.

2015-09-16T18:09:00,219 INFO [main] io.druid.guice.JsonConfigurator - Loaded class[class io.druid.server.DruidNode] from props[druid.] as [DruidNode{serviceName=‘druid/internal-hadoop-indexer’, host=‘ip-172-31-20-69.ap-southeast-1.compute.internal’, port=0}]

2015-09-16T18:09:00,224 ERROR [main] io.druid.cli.CliHadoopIndexer - failure!!!

java.lang.reflect.InvocationTargetException

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.7.0_71]

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) ~[?:1.7.0_71]

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.7.0_71]

at java.lang.reflect.Method.invoke(Method.java:606) ~[?:1.7.0_71]

at io.druid.cli.CliHadoopIndexer.run(CliHadoopIndexer.java:120) [druid-services-0.8.0.jar:0.8.0]

at io.druid.cli.Main.main(Main.java:91) [druid-services-0.8.0.jar:0.8.0]

Caused by: com.google.inject.ProvisionException: Guice provision errors:

  1. Unknown provider[mysql] of Key[type=io.druid.metadata.SQLMetadataConnector, annotation=[none]], known options[[derby]]

at io.druid.guice.PolyBind.createChoiceWithDefault(PolyBind.java:67)

while locating io.druid.metadata.SQLMetadataConnector

for parameter 0 at io.druid.indexer.SQLMetadataStorageUpdaterJobHandler.<init>(SQLMetadataStorageUpdaterJobHandler.java:42)

while locating io.druid.indexer.SQLMetadataStorageUpdaterJobHandler

at io.druid.guice.PolyBind.createChoiceWithDefault(PolyBind.java:67)

while locating io.druid.indexer.MetadataStorageUpdaterJobHandler

1 error

at com.google.inject.internal.InjectorImpl$3.get(InjectorImpl.java:1014) ~[guice-4.0-beta.jar:?]

at com.google.inject.internal.InjectorImpl.getInstance(InjectorImpl.java:1040) ~[guice-4.0-beta.jar:?]

at io.druid.cli.CliInternalHadoopIndexer.run(CliInternalHadoopIndexer.java:103) ~[druid-services-0.8.0.jar:0.8.0]

at io.druid.cli.Main.main(Main.java:91) ~[druid-services-0.8.0.jar:0.8.0]

… 6 more

Please help. It’s blocker. Can’t move ahead.

Thanks in advance,

Aman

Can you try including the common druid configuration in the classpath and includes all your extensions and mysql credentials?

Hi,

Thanks for the reply.

I have tried out with the as mentioned. Still it doesn’t worked out. Could you please have a look in config file. See if I am missing something there.

Attaching spec file and commonruntimeconfig.

Stack trace below.

basicStatsSpecs.json (1.9 KB)

common.runtime.properties (1.83 KB)

It looks like you didn’t have mysql-metadata-storage included in the classpath? Specifically these guys, jdbi-[version].jar. mysql-connector-java-[version].jar, mysql-metadata-storage-[version].jar

HI,

Thanks it worked.

Aman