Number of active Hadoop indexing tasks is capped at 3

Hello Druid users, does anyone have experience in changing how many Hadoop indexing tasks are allowed to run? Our configuration has a single overlord node running in local mode, without middle managers. We have a separate Hadoop cluster Druid uses for indexing. However, it seems with three active tasks, any other tasks added have to wait in the pending queue.

Is this limited to the number of cores on the machine - 1?

Appreciate the help.

It si limited by the config druid.worker.capacity which is set to cpu cores - 1 by default. Setting it to a higher number in your overlord runtime.props should fix this.

Thanks Nishant. Thought I had tried that before. I tried again, and it did work.