Overlord Node error with MYSQL

I am trying to run start a Overlord node in druid to test locally. Below are the settings file. I get the below error.
Can someone have a look and let me know if there are any issues with the spec file or the way I am trying to start? because based on the exception looks like it is trying to connect to port 1527.

Druid - a distributed column store.

Copyright 2012 - 2015 Metamarkets Group Inc.

Licensed under the Apache License, Version 2.0 (the “License”);

you may not use this file except in compliance with the License.

You may obtain a copy of the License at

http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software

distributed under the License is distributed on an “AS IS” BASIS,

WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.

See the License for the specific language governing permissions and

limitations under the License.

druid.service=overlord

druid.host=localhost

druid.port=8089

Curator Module (All nodes)

druid.zk.service.host=localhost

Metrics Module (All nodes)

#druid.monitoring.monitors=[“com.metamx.metrics.SysMonitor”,“com.metamx.metrics.JvmMonitor”]

druid.db.connector.connectURI=jdbc:mysql://localhost:3306/druid

druid.db.connector.user=druidtest

druid.db.connector.password=druidtest

Emitter Module (All nodes)

druid.emitter=logging

Task Log Module (Overlord and MiddleManager node)

Indexing Service Discovery Module (All nodes)

druid.selectors.indexing.serviceName=overlord

#druid.indexer.runner.type=remote

#druid.indexer.storage.type=db

java -Xmx256m -Duser.timezone=PST -Dfile.encoding=UTF-8 -classpath config/_common:config/overlord:lib/* io.druid.cli.Main server overlord

Error Log

It looks like it’s trying to connect to derby, but you intend to use mysql. Try setting

druid.metadata.storage.type=mysql

Hi Raguvind,

As sahner suggested, you need to define:

druid.metadata.storage.type=mysql

I think you also need to define druid.metadata.storage.connector.connectURI and other parameters, see “Metadata Storage” in http://druid.io/docs/latest/configuration/

Otherwise the port will default to 1527.

  • Jon