Overlord uses ip-number to pod instead of dns-name to service

Hi, i run druid in MiniKube.

I try to create a supervisor for KafkaIndexingService.

The problem is that it seems like Overlord don’t use the internal DNS names for services but the ip-number to the pod?

INFO [Curator-PathChildrenCache-1] io.druid.indexing.overlord.TaskRunnerUtils - Task [%s] location changed to [TaskLocation{host=‘172.17.0.13’, port=8100, tlsPort=-1}].

This in turn gives me:

INFO [%s] io.druid.indexing.kafka.KafkaIndexTaskClient - submitRequest failed for [http://172.17.0.13:8100/druid/worker/v1/chat/taskid/offsets/current], with message [Connection refused (Connection refused)]

So should overlord use DNS-names? Could there be an extension i miss?

Br,

Johan

Hi Johan,

You could try setting druid.host to the desired DNS names on each machine in the common runtime properties.

Thanks,

Jon