Problem with KafkaSupervisor after updating druid from 0.10.0 to 0.10.1

Hi!
We are using Kafka Indexing Service (KafkaSupervisor) to pull data from existing Kafka topic.
This worked fine until I tried to update druid to 0.10.1 today (in out test-cluster).
Supervisor was running and also visible in the ‘new’ coordinator console, but no task were starting.
After searching the logs it was clear, there is a problem.
2017-10-12T11:15:56,991 WARN [KafkaSupervisor-analytics_raw_tracking_supervisor] io.druid.indexing.kafka.supervisor.KafkaSupervisor - Unable to get partition data from Kafka for brokers [hadoop11x:9092,hadoop11x:9092,hadoop11x:9092], are the brokers up?
org.apache.kafka.common.errors.InterruptException: java.lang.InterruptedException
at org.apache.kafka.clients.consumer.internals.ConsumerNetworkClient.maybeThrowInterruptException(ConsumerNetworkClient.java:417) ~[kafka-clients-0.10.2.0.jar:?]
at org.apache.kafka.clients.consumer.internals.ConsumerNetworkClient.poll(ConsumerNetworkClient.java:242) ~[kafka-clients-0.10.2.0.jar:?]
at org.apache.kafka.clients.consumer.internals.ConsumerNetworkClient.poll(ConsumerNetworkClient.java:188) ~[kafka-clients-0.10.2.0.jar:?]
at org.apache.kafka.clients.consumer.internals.Fetcher.getTopicMetadata(Fetcher.java:282) ~[kafka-clients-0.10.2.0.jar:?]
at org.apache.kafka.clients.consumer.internals.Fetcher.getAllTopicMetadata(Fetcher.java:262) ~[kafka-clients-0.10.2.0.jar:?]
at org.apache.kafka.clients.consumer.KafkaConsumer.listTopics(KafkaConsumer.java:1370) ~[kafka-clients-0.10.2.0.jar:?]
at io.druid.indexing.kafka.supervisor.KafkaSupervisor.updatePartitionDataFromKafka(KafkaSupervisor.java:757) [druid-kafka-indexing-service-0.10.1.jar:0.10.1]
at io.druid.indexing.kafka.supervisor.KafkaSupervisor.runInternal(KafkaSupervisor.java:678) [druid-kafka-indexing-service-0.10.1.jar:0.10.1]
at io.druid.indexing.kafka.supervisor.KafkaSupervisor$RunNotice.handle(KafkaSupervisor.java:516) [druid-kafka-indexing-service-0.10.1.jar:0.10.1]
at io.druid.indexing.kafka.supervisor.KafkaSupervisor$2.run(KafkaSupervisor.java:334) [druid-kafka-indexing-service-0.10.1.jar:0.10.1]
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_111]
at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_111]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [?:1.8.0_111]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [?:1.8.0_111]
at java.lang.Thread.run(Thread.java:745) [?:1.8.0_111]
Caused by: java.lang.InterruptedException
… 15 more

Can anyone tell me what the problem is? Maybe Kafka client version?

We are also using Tranquility 0.8.2 to pull data from kafka, that worked fine after the update. Tranquility does not match
our requirements, because we want to use numeric dimensions which seams to be a problem with Tranquility.

(CDH5.7.1, Hadoop2.6.0, Kafka 0.9.0 (should be 0.10.0, but it worked before druid update))

Regards,
Alex

Druid 0.10.1 uses Kafka-client version 0.10.0.2 so probably you need to upgrade your Kafka cluster to Kafka 0.10.X or higher version.

-Parag

We already discussed that and updateing Kafka is not a solution for us at the moment, because we would run into some troubles.

If we do an update, I will let you know if it fix our problem.