pull-deps tool download hdfs extensions problem

Hi, I want to download target hadoop version about 2.2.0, but the result is hadoop-dependencies is 2.2.0 version jars and druid-hdfs-storage is still 2.3.0.
How I can do to download druid-hdfs-storage become 2.2.0. here is my cmd, thanks.

The hadoop version you pass to pull-deps only affects what is used for the purposes of running MR-based indexing jobs. The HDFS storage extension always uses 2.3.0. Is that causing a problem for you?

ok, thanks. I’m just curious why druid-hdfs-storage hadoop jar version is not the same with hadoop-dependencies.
I tried in my environment(hadoop version 2.2.0) , it runs good.

在 2016年7月1日星期五 UTC+8上午4:50:15,Gian Merlino写道: