Pydruid not installing completely?

Hi,

I’m trying to install pydruid, but there seems to be a problem. I use the command “pip install pydruid[pandas]”, but it tells me that pydruid version 0.2.3 doesn’t support pandas. Also when I install pydruid it doesn’t seem to have the complete code. For example on the pydruid github, in the file client.py, there is an entire block of code starting with “class BaseDruidClient(object):”, that doesn’t show up in the installed version on my computer.

Is there anyway to upload the download or anything like that?

Thanks a lot

Thomas

The latest version on pypi is 0.2.3.

The version on github (0.2.4) is not released yet.

If you want to install the latest version from github you can add something like that in your setup.py: