Query Granularity not working when set to "all" for Kafka stream Ingestion

Hey,
I have been trying a Roll-up feature with queryGranularity set to “all”. It is working fine with Batch Ingestion, but it is failing for Stream Ingestion (kafka) and this is how the tasks log look like:
Task completed with status: {
“id” : “index_kafka_PG_roll_up_4_a6b7e3343a731b4_gdkmfmlj”,
“status” : “FAILED”,
“duration” : 1966,
“errorMsg” : “org.apache.druid.java.util.common.ISE: Could not allocate segment for row with timestamp[2021-12-02T…”,
“location” : {
“host” : null,
“port” : -1,
“tlsPort” : -1
}
}

Granularity Spec:
“granularitySpec”: {
“type”: “uniform”,
“queryGranularity”: “ALL”,
“segmentGranularity”: “ALL”,
“rollup”: true
},

Can anybody tell if this is a bug or am I missing something here?

Hey Nimish! ALL is, to quote @Gian_Merlino2:

somewhat unconventional, but there is nothing wrong with it, and it actually makes a lot of sense for tables that are meant to be used for lookups or dimensions rather than main fact tables.
Enable allocating segments at ALL granularity. by gianm · Pull Request #12003 · apache/druid · GitHub

I wonder if you’ve in fact just hit a use case that the PR above may relate to.

If you definitely need to use ALL for Kafka, it may be worth logging an issue in Github?