Router configuration

Hi,
I am having druid cluster setup where two nodes for each component.

as per router service document it says to use the below config

druid.router.defaultBrokerServiceName=druid:broker-cold

druid.router.coordinatorServiceName=druid:coordinator

druid.router.tierToBrokerMap={“hot”:“druid:broker-hot”,"_default_tier":“druid:broker-cold”}

I am not getting understand what to use for those variables. I have used like below and its throwing below error.

Service discovery

druid.router.defaultBrokerServiceName=p1-lax-broker-1:8082

druid.router.coordinatorServiceName=p1-lax-corovl-1:8081

druid.router.tierToBrokerMap={“hot”:“p1-lax-broker-2:8082”,“p1-lax-broker-1:8082”:“p1-lax-broker-1:8082”}

ERROR:

2019-05-15 23:29:53,318 INFO o.a.d.j.u.c.l.Lifecycle [main] Successfully started lifecycle [module]

2019-05-15 23:29:57,943 ERROR o.a.d.s.r.QueryHostFinder [qtp1134043959-63] WTF?! No server found for serviceName[p1-lax-broker-1:8082]. Using backup

2019-05-15 23:29:57,944 ERROR o.a.d.s.r.QueryHostFinder [qtp1134043959-63] WTF?! No backup found for serviceName[p1-lax-broker-1:8082]. Using default[p1-lax-broker-1:8082]

2019-05-15 23:29:57,949 ERROR o.a.d.s.r.QueryHostFinder [qtp1134043959-63] Catastrophic failure! No servers found at all! Failing request!: {class=org.apache.druid.server.router.QueryHostFinder}

2019-05-15 23:29:57,978 INFO o.a.d.j.u.e.c.LoggingEmitter [qtp1134043959-63] Event [{“feed”:“alerts”,“timestamp”:“2019-05-16T06:29:57.973Z”,“service”:“druid/router”,“host”:“p1-lax-corovl-1.advdc.com:8888”,“version”:“0.14.1-incubating”,“severity”:“component-failure”,“description”:“Catastrophic failure! No servers found at all! Failing request!”,“data”:{“class”:“org.apache.druid.server.router.QueryHostFinder”}}]

2019-05-15 23:29:57,980 WARN o.e.j.s.HttpChannel [qtp1134043959-63] /druid/v2/sql

org.apache.druid.java.util.common.ISE: No default server found!

Please suggest me on this**.**

Hi,

I think the value that is referenced here should match the druid.service value you put in your brokers config.

Is that the case ?

When I have all components one server then router is working fine with default values.

Did you try to configure without defining hot/cold brokers ?

My configuration is similar as yours (multi nodes, router has its own) and here is what I have in configuration :

on brokers, in runtime.properties

druid.service=druid/broker

Same for all nodes with their own names (druid/historical, druid/router)

And for router, my 2 parameters look like this :

druid.router.defaultBrokerServiceName=druid/broker
druid.router.coordinatorServiceName=druid/coordinator

And the cluster is up and fine (I have others issues, but that’s not the point ^^)

Yes, I have tried with out defining hot/cold brokers and using the parameters you have given but I am getting below error.

Did you try to configure without defining hot/cold brokers ?

My configuration is similar as yours (multi nodes, router has its own) and here is what I have in configuration :

on brokers, in runtime.properties

druid.service=druid/broker

Same for all nodes with their own names (druid/historical, druid/router)

And for router, my 2 parameters look like this :

druid.router.defaultBrokerServiceName=druid/broker
druid.router.coordinatorServiceName=druid/coordinator

And the cluster is up and fine (I have others issues, but that’s not the point ^^)

When I have all components one server then router is working fine with default values.

Hi,

I think the value that is referenced here should match the druid.service value you put in your brokers config.

Is that the case ?

Hi,
I am having druid cluster setup where two nodes for each component.

as per router service document it says to use the below config

druid.router.defaultBrokerServiceName=druid:broker-cold

druid.router.coordinatorServiceName=druid:coordinator

druid.router.tierToBrokerMap={“hot”:“druid:broker-hot”,"_default_tier":“druid:broker-cold”}

I am not getting understand what to use for those variables. I have used like below and its throwing below error.

Service discovery

druid.router.defaultBrokerServiceName=p1-lax-broker-1:8082

druid.router.coordinatorServiceName=p1-lax-corovl-1:8081

druid.router.tierToBrokerMap={“hot”:“p1-lax-broker-2:8082”,“p1-lax-broker-1:8082”:“p1-lax-broker-1:8082”}

ERROR:

2019-05-15 23:29:53,318 INFO o.a.d.j.u.c.l.Lifecycle [main] Successfully started lifecycle [module]

2019-05-15 23:29:57,943 ERROR o.a.d.s.r.QueryHostFinder [qtp1134043959-63] WTF?! No server found for serviceName[p1-lax-broker-1:8082]. Using backup

2019-05-15 23:29:57,944 ERROR o.a.d.s.r.QueryHostFinder [qtp1134043959-63] WTF?! No backup found for serviceName[p1-lax-broker-1:8082]. Using default[p1-lax-broker-1:8082]

2019-05-15 23:29:57,949 ERROR o.a.d.s.r.QueryHostFinder [qtp1134043959-63] Catastrophic failure! No servers found at all! Failing request!: {class=org.apache.druid.server.router.QueryHostFinder}

2019-05-15 23:29:57,978 INFO o.a.d.j.u.e.c.LoggingEmitter [qtp1134043959-63] Event [{“feed”:“alerts”,“timestamp”:“2019-05-16T06:29:57.973Z”,“service”:“druid/router”,“host”:“p1-lax-corovl-1.advdc.com:8888”,“version”:“0.14.1-incubating”,“severity”:“component-failure”,“description”:“Catastrophic failure! No servers found at all! Failing request!”,“data”:{“class”:“org.apache.druid.server.router.QueryHostFinder”}}]

2019-05-15 23:29:57,980 WARN o.e.j.s.HttpChannel [qtp1134043959-63] /druid/v2/sql

org.apache.druid.java.util.common.ISE: No default server found!

Please suggest me on this**.**

You received this message because you are subscribed to the Google Groups “Druid User” group.

To unsubscribe from this group and stop receiving emails from it, send an email to druid...@googlegroups.com.

To post to this group, send email to druid...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/druid-user/9c3b0711-7de7-47b9-a438-d4784d6b82e7%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

well, if we just give druid.router.defaultBrokerServiceName=druid/broker, how does it know where is our broker service running?

also, can you please suggest how to configure hot/cold brokers?

For what I know, all service discovery is handled by zookeeper

Sorry, I can’t help any further with hot/cold brokers, I didn’t experience it myself

Acutally I was upgrading druid version from 13.0 to latest and did not add the property druid.sql.enable=true on common runtime properties.

Using below properties my issue got resolved.

druid.router.defaultBrokerServiceName=druid/broker
druid.router.coordinatorServiceName=druid/coordinator

Thanks Guillaume Lhermenier for your help.

The error you are seeing in the screenshot is most likely caused by you not enabling SQL the docs ( http://druid.io/docs/latest/operations/druid-console.html ) take you to ( http://druid.io/docs/latest/querying/sql.html ) which tells you:

“To enable Druid SQL, make sure you have set druid.sql.enable=true either in your common.runtime.properties or your Broker’s runtime.properties.”

Hope this helps!