Router Console Buge: Huge discrepancy when Coordinator and Router console reports data availability

Screen Shot below: Router shows 0.0% available, but Legacy Coordinator shows fully available. And I can get data when I send a scan query. Thus I believe the Router console has a bug.

Hi Xuany Li,

I just tried in druid 0.15 and it works well.

Does it show unavailable always or after some time it updates the status?

What is your exact druid version?

Does it happen every time in your instance?

Thanks and Regards,

Vaibhav

Hi Vaibhav, I use 0.15.1 version. I refresh the router pages many times but it always shows 0.0 availability. But when I reboot the ec2 instance, the router console shows fully availability.

Could you try a new ingestion and see if the issue is reproducible? I will also try in 0.15.1 once you confirm.

Thanks and Regards,

Vaibhav

Hi Vaibhav, the ingestion tasks in the screen shot are indeed started one following another when I see the top is 0.0% available. We use EMR cluster to do the hadoop ingestion task. Maybe there’s problem inside EMR, not the problem of Druid.

Please paste here your router configuration. Are you trying to issue an API call to there router to get the availability of datasources?

Rommel Garcia

Hi Rommel,

Thanks for your reply. The router’s configuration below. When I send scan query to the router, it could return desired data even if the router show’s 0 availability.

Let me introduce more background here. Our team bind a broker and a historical to a certain tier. And the default broker was previously configured to watch only _default_tier when I meet such discrepancy.

After I restart the router process and remove the default broker’s watchedList, I haven’t meet the discrepancy yet. I figure that the discrepancy may occur if the default broker doesn’t watch all tiers.

Best,

Xuanyi

druid.service=druid/router

druid.plaintextPort=8888

HTTP proxy

druid.router.http.numConnections=50

druid.router.http.readTimeout=PT5M

druid.router.http.numMaxThreads=100

druid.server.http.numThreads=100

Service discovery

druid.router.defaultBrokerServiceName=druid/broker

druid.router.coordinatorServiceName=druid/coordinator

druid.router.tierToBrokerMap={“AAA”:“druid/broker-AAA”,“BBB:“druid/broker-BBB”,“CCC”:“druid/broker-CCC”,“staging”:“druid/broker-staging”,”_default_tier":“druid/broker”}

Management proxy to coordinator / overlord: required for unified web console.

druid.router.managementProxy.enabled=true