Strange issue with combining firehose

I’m trying to perform a delta ingestion using a combining firehose.

Here is the relevant part of the config:

"ioConfig": { 

  "type": "index",

  "firehose": {

    "type": "combining",

    "delegates": [

      { 

        "type": "static-s3",

        "uris": [

          "s3://mybucket/20170831/rtb.20170831.23.gz",

          "s3://mybucket/20170901/rtb.20170901.00.gz",

            ...

          "s3://mybucket/20170902/rtb.20170902.00.gz"

        ]

      },

      { 

        "type": "ingestSegment",

        "dataSource": "rtb",

        "interval": [

          "2017-09-01T00:00:00.000Z/2017-09-01T23:59:59.999Z"

        ]

      }

    ]

  }

},

But jobs submitted with this config result in this error message:

{“error”:“Format requires a ‘/’ separator: [ (through reference chain: org.apache.druid.indexing.common.task.IndexTask[“spec”]->org.apache.druid.indexing.common.task.IndexIngestionSpec[“ioConfig”]->org.apache.druid.indexing.common.task.IndexIOConfig[“firehose”]->org.apache.druid.segment.realtime.firehose.CombiningFirehoseFactory[“delegates”]->java.util.ArrayList[1]->org.apache.druid.indexing.firehose.IngestSegmentFirehoseFactory[“interval”])”}

Obviously, there IS a ‘/’ separator in the interval, so I’m at a loss what to do.

I tried this with an incubator snapshot from a couple days ago, but I had the same problem with 12.0.

Thanks in advance for any illumination!

Just shooting from the hip on my phone: are you sure interval shouldn’t be a single string rather than an array?

(I think that is the issue, but the error could be better!)

Of course! Yes, that solved it. Thanks!