Timeseries queries are not zero-filled

As per the documentation, the results of the Timeseries should be zero-filled by default.
I am using druid 0.8.2 but I don’t get any zero-filled rows in timeseries queries. I have also tried setting “skipEmptyBuckets”: “false” but the result is the same.

What could be the issue?

Hmmm, a few people have reported this issue. I believe https://github.com/druid-io/druid/pull/2259 is working on a fix.