Trouble with Druid Basic Security -> druid.auth.authentication.anonymous.type=anonymous

Please don’t ask why…lol…but I am being asked to set up Druid Basic Security with an authentication chain of:

druid.auth.authenticatorChain=[“BasicAuthenticator”, “anonymous”]

My Basic Authentication configuration works perfectly, but things error out when I try to add the secondary anonymous authenticator.

According to the Druid current documentation at http://druid.io/docs/latest/design/auth.html :

What version of Druid are you on? The “anonymous” one was added in 0.13.0.

12.3

I was wondering if the documentation pertained to 12.3…i kind of wish there was a way to revert to older docs rather than only the latest.

Planning to upgrade to 13.0 so this was good to know.

Thank u.

You can replace latest in the URL with the version number to access older docs, e.g.: http://druid.io/docs/0.12.3/design/auth.html

Thanks a million Jonathan.

Any chance since I have your time…I could ask you for advice regarding the consumerProperties section of the ioConfig in a Kafka indexing service supervisor?

I have tls enabled in Druid 0.12.3

I have a path and password for both the truststore and keystore similar to this :

https://gist.github.com/gianm/4ebe7861fae67a46758011d27e7364b1

…in the common.runtime.properties of my nodes.

For some reason I can’t any combination of these properties to work (submitting to Kafka broker on enabled ssl port…and entering passwords of course):

  consumerProperties: {
        "ssl.truststore.password": "",
        "ssl.keystore.password": "",
        "ssl.key.password": ""
    }
}

The supervisor deploys…but data never ingests from Kafka.

Any thoughts?

I haven’t worked much with deploying Kafka, but I would guess that you need to specify in the consumerProperties the truststore and keystore (if the Kafka broker has client cert checks enabled): https://docs.confluent.io/current/kafka/authentication_ssl.html#clients

The Kafka consumerProperties are entirely separate from Druid’s TLS configurations.

Thank you Jonathan