Unable to get flattenSpec working

Environment:
Vagrant Ubuntu 16

Druid 0.9.1

tranquility 0.8.2

zookeeper 3.4.6

Followed the Quickstart from http://druid.io/docs/latest/tutorials/quickstart.html

Tranquility Server config:

{
  "dataSources": [
    {
      "spec": {
        "dataSchema": {
          "dataSource": "raw_events",
          "metricsSpec": [
            {
              "type": "count",
              "name": "count"
            }
          ],
          "granularitySpec": {
            "segmentGranularity": "hour",
            "queryGranularity": "none",
            "type": "uniform"
          },
          "parser": {
            "type": "string",
            "parseSpec": {
              "format": "json",
              "timestampSpec": {
                "column": "at",
                "format": "posix"
              },
              "flattenSpec": {
                "useFieldDiscovery": true,
                "fields": [
                  "verb",

                  {
                    "type": "path",
                    "name": "actor.type",
                    "expr": "$.actor.type"
                  },
                  {
                    "type": "path",
                    "name": "actor_type",
                    "expr": "$['actor']['type']"
                  },
                  {
                    "type": "path",
                    "name": "direct_object_type",
                    "expr": "$.direct_object.type"
                  }
                ]
              },
              "dimensionsSpec": {
                "dimensions": [
                  "verb",
                  "actor.type",
                  "direct_object_type",
                  "actor_type"
                ]
              }
            }
          }
        },
        "tuningConfig": {
          "type": "realtime",
          "windowPeriod": "PT10M",
          "intermediatePersistPeriod": "PT10M",
          "maxRowsInMemory": 75000
        }
      },
      "properties": {
        "task.partitions": "1",
        "task.replicants": "1"
      }
    }
  ],
  "properties": {
    "zookeeper.connect": "localhost",
    "http.port": "8200",
    "http.threads": "40"
  }
}

Curl request:

curl -XPOST -H’Content-Type: application/json’ -s -d ‘{“id”:“12333”,“actor”:{“id”:“123123”,“ab_segment”:“H”,“cohort_d”:“D2016-10-11”,“cohort_w”:“W2016-10-09”,“cohort_m”:“M2016-10”,“cohort_y”:“Y2016”,“type”:“user”},“verb”:“foregrounded”,“direct_object”:{“type”:“app”,“user_agent”:“Poshmark/2.52.01 (iPhone; iOS 10.2.1; Scale/2.00)”,“app_type”:“iphone”,“app_version”:“2.52.01”},“using”:{“type”:“device”,“openudid”:null,“odin1”:null,“ven_did”:null,“adv_did”:null,“pm_device_id”:“ios2:123123123”,“push_token”:null,“payment_info”:{“ape”:false,“vmi”:false}},“from”:“66.87.81.106”,“at”:1498754830.6857758}’ http://10.151.157.167:8200/v1/post/raw_events

But when I look at coordinator for metadata :

curl -XPOST -H ‘Content-Type:application/json’ -d ‘{“queryType” : “segmentMetadata”,“dataSource”: “raw_events”}’ http://localhost:8082/druid/v2/?pretty

{

“id” : “raw_events_2017-06-29T15:00:00.000Z_2017-06-29T16:00:00.000Z_2017-06-29T15:32:45.018Z”,

“intervals” : [ “2017-06-29T15:00:00.000Z/2017-06-29T15:37:14.001Z” ],

“columns” : {

"__time" : {

  "type" : "LONG",

  "hasMultipleValues" : false,

  "size" : 2050,

  "cardinality" : null,

  "minValue" : null,

  "maxValue" : null,

  "errorMessage" : null

},

"actor.type" : {

  "type" : "STRING",

  "hasMultipleValues" : false,

  "size" : 0,

  "cardinality" : 1,

  "minValue" : "",

  "maxValue" : "",

  "errorMessage" : null

},

"actor_type" : {

  "type" : "STRING",

  "hasMultipleValues" : false,

  "size" : 0,

  "cardinality" : 1,

  "minValue" : "",

  "maxValue" : "",

  "errorMessage" : null

},

"count" : {

  "type" : "LONG",

  "hasMultipleValues" : false,

  "size" : 1640,

  "cardinality" : null,

  "minValue" : null,

  "maxValue" : null,

  "errorMessage" : null

},

"direct_object_type" : {

  "type" : "STRING",

  "hasMultipleValues" : false,

  "size" : 1020,

  "cardinality" : 1,

  "minValue" : "asdas",

  "maxValue" : "asdas",

  "errorMessage" : null

},

"verb" : {

  "type" : "STRING",

  "hasMultipleValues" : false,

  "size" : 1722,

  "cardinality" : 4,

  "minValue" : "foregrounded",

  "maxValue" : "update",

  "errorMessage" : null

}

},

“size” : 7662,

“numRows” : 205,

“aggregators” : null,

“queryGranularity” : null

} ]

My actor.type column has cardinality 0. I have tried both the versions of path a.b & [‘a’][‘b’], But both didn’t work. My data is getting ingested because I can see my verb column cardinality go up to 4. But unable to parse out nested attributes.

Should I enable specific extension for flatten spec?

I am starting tranquility server like:

bin/tranquility server -configFile /gp/druid/conf/server.json > /gp/log/tranquility_server.log &

Tried with druid 0.10.0 as well same results.

Looked at other posts on this forum but couldn’t get further.